1) instalar paquete eclipse

apt-get install eclipse

2) Si tiene máquina virtual 1.4, se podrá ejecutar sin problemas -> FIN , si no la tiene o es mayor a 1.4, intentando ejectutar sale el “ERROR”:

“A Java Runtime Environment (JRE) or Java Development Kit (JDK) must be available in order to run Eclipse. No Java virtual machine was found after searching the following locations:/usr/lib/j2sdk1.4-sun/bin/java”

3) Si ho tiene instalado JVM, se tiene que descargar los paquetes jre o jdk

apt-get install sun-java6-jre

En este caso estamos bajando el 1.6
Reintentando abrir ejectutar eclipse: Se repite el “ERROR”

4) Para solucionar editar el archivo del eclipse ubicado en: /etc/eclipse/java_home

nano /etc/eclipse/java_home

5) Agregar la ruta del jvm que descargaste, para saber cual ruta, ir al directorio: /usr/lib/jvm/ y ver las carpetas listando con (ls)
en mi caso, se debe agregar la ruta:

/usr/lib/jvm/java-6-sun-1.6.0.00

ASí es como quedó mi archivo /etc/eclipse/java_home

Un ejemplo: GNU nano 1.3.12 Fichero: /etc/eclipse/java_home
# This file determines the search order the Eclipse Platform uses to find a
# compatible JAVA_HOME. This setting may be overridden on a per-user basis by
# altering the JAVA_HOME setting in ~/.eclipse/eclipserc.

/usr/lib/jvm/java-6-sun-1.6.0.00
/usr/lib/jvm/java-gcj
/usr/lib/kaffe/pthreads
/usr/lib/jvm/java-1.5.0-sun
/usr/lib/j2se/1.5
/usr/lib/j2se/1.4
/usr/lib/j2sdk1.5-ibm
/usr/lib/j2sdk1.4-ibm
/usr/lib/j2sdk1.5-sun
/usr/lib/j2sdk1.4-sun

Luego ejecutar eclipse